Juniper para MikroTik – comandos BGP

Juniper para MikroTik – comandos BGP

Sobre a série Juniper to MikroTik

No mundo da engenharia de rede, aprender uma nova sintaxe para um NOS pode ser assustador se você precisar de uma configuração específica rapidamente. Juniper é uma opção popular para provedores de serviços / data centers e é amplamente implantado em todo o mundo. 

Esta é uma continuação da pedra de Rosetta para a série de sistemas operacionais de rede. Estaremos trabalhando em vários protocolos em uma série de postagens para ajudá-lo a se mover rapidamente entre diferentes ambientes. 

Embora muitos comandos tenham quase exatamente as mesmas informações, outros são os mais próximos possíveis. Como nem sempre há uma correspondência exata, às vezes você pode ter que executar dois ou três comandos para obter as informações necessárias. 

Usando EVE-NG para teste

Conduzimos todos esses testes utilizando EVE-NG e a topologia vista abaixo. 

Juniper CommandMikroTik Command
show bgp summaryrouting bgp peer print brief
show bgp neighborrouting bgp peer print status
show route advertising-protocol bgp 172.31.254.2routing bgp advertisements print peer=peer_name
show route receive-protocol bgp 172.31.254.2ip route print where received-from=peer_name
show route protocol bgpip route print where bgp=yes
clear bgp neighbor 172.31.254.2 soft-inboundrouting bgp peer refresh peer_name
clear bgp neighbor 172.31.254.2 softrouting bgp peer resend peer_name
set routing-options autonomous-system 1/routing bgp instance
set default as=2
set protocols bgp group EBGP type external
set protocols bgp group EBGP peer-as 2
set protocols bgp group EBGP neighbor 172.31.254.2
/routing bgp peer
add name=PEER-1 remote-address=172.31.254.1 remote-as=1
set policy-options policy-statement REDIS-CONNECTED term 1 from protocol direct
set policy-options policy-statement REDIS-CONNECTED term 1 then accept
set protocols bgp group EBGP export REDIS-CONNECTED
/routing bgp network
add network=100.89.88.0/24
add network=100.89.87.0/24
add network=100.89.86.0/24
set routing-options static route 0.0.0.0/0 discard
set protocols bgp group EBGP export SEND-DEFAULT
set policy-options policy-statement SEND-DEFAULT term 1 from protocol static
set policy-options policy-statement SEND-DEFAULT term 1 from route-filter 0.0.0.0/0 exact
set policy-options policy-statement SEND-DEFAULT term 1 then accept
/routing bgp peer
add default-originate-always name=PEER-1 remote-address=172.31.254.1 remote-as=1

Mais por vir

Existem tantos comandos a serem considerados para o BGP, provavelmente poderíamos ter adicionado perto de 100, mas decidimos listar os comandos que usamos com mais frequência para começar e iremos adicionar à lista de comandos do BGP, bem como outros como OSPF, MPLS e VLANs em postagens futuras. 

Deixe uma resposta

0