Como configurar um roteador Mikrotik como cliente DHCP-PD (delegação de prefixo)

Como configurar um roteador Mikrotik como cliente DHCP-PD (delegação de prefixo)

Com o tempo, mais e mais IPS fornecem endereços IPv6 ao roteador (e aos clientes por trás dele) via DHCP-PD. Para ser mais detalhado, isso é DHCPv6 com delegação de delegação de prefixo . Isso permite que o ISP forneça mais de uma sub-rede, o que permite que você use várias redes sem NAT. E esqueça o NAT e o IPv6 – não há uma maneira padronizada de fazer isso, e vai quebrar muito. A ideia com o PD também é que você pode usar roteadores domésticos normais e colocá-los em cascata, o que requer que cada roteador forneça um prefixo / sub-rede menor para o próximo roteador. Tudo deve funcionar sem configuração – esse era pelo menos o plano do grupo de trabalho da IETF .

De qualquer forma, vamos parar com a teoria e fornecer algum código. No meu caso meu provedor exige que meu roteador estabeleça um túnel pppoe, que fornece ao meu roteador um IPv4 automaticamente. No meu caso, a configuração se parece com isto:

/interface pppoe-client add add-default-route=yes disabled=no interface=ether1vlanTransitModem name=pppoeDslInternet password=XXXX user=XXXX

Para IPv6, precisamos habilitar o cliente DHCPv6 com o seguinte comando:

/ipv6 dhcp-client add interface=pppoeDslInternet pool-name=poolIPv6ppp use-peer-dns=no

Mas um cheque com

/ipv6 dhcp-client print

só vai mostrar que o cliente está “procurando…”. A razão para isso é que você provavelmente bloqueia as conexões de entrada da Internet – Se você não filtrar -> bad boy! :-). Você precisa permitir respostas DHCP do servidor.

/ipv6 firewall filter add chain=input comment="DHCPv6 server reply" port=547 protocol=udp src-address=fe80::/10

Agora você deve ver algo assim

Neste caso, obtivemos um prefixo / 60 delegado do ISP, que conta para 16/64 sub-redes. A última etapa que você precisa é configurar os endereços IP em suas redes internas. Sim, você poderia apenas adicionar os endereços IP estaticamente, mas se o provedor alterar a sub-rede após uma desconexão, você precisará reconfigurá-la novamente. É melhor configurar o roteador para atribuir dinamicamente os endereços IP delegados às interfaces internas. Você só precisa chamar o seguinte para cada uma de suas interfaces internas:

/ipv6 address add from-pool=poolIPv6ppp interface=vlanInternal

O comando a seguir deve mostrar os prefixos atualmente atribuídos às várias redes internas

/ipv6 address print

Ei, IPv6 não é tão complicado. 

Deixe uma resposta

0