Cisco para MikroTik – tradução de comando – OSPF

Cisco para MikroTik – tradução de comando – OSPF

No mundo da engenharia de rede, aprender uma nova sintaxe para um NOS pode ser opressor se você precisar de um conjunto específico de configurações em um curto espaço de tempo. A estrutura de comando para RouterOS pode ser um pouco desafiadora se você estiver acostumado com os comandos Cisco CLI.

Se você já trabalha em rede há um bom tempo, há uma boa chance de você ter começado com o equipamento Cisco, então é útil fazer comparações entre os comandos, especialmente se você está tentando construir uma rede com um roteador MikroTik e Cisco.

Este é o segundo post de uma série que cria uma pedra de Roseta essencialmente entre IOS e RouterOS. Planejamos abordar outras comparações de comando, como MPLS, VLANs e operações básicas para tornar mais fácil para engenheiros de rede treinados em Cisco IOS implementar com sucesso dispositivos Mikrotik / RouterOS.

Clique aqui para ver o primeiro artigo desta série – “ Tradução de comandos Cisco para MikroTik BGP”

Embora muitos comandos tenham quase exatamente as mesmas informações, outros são os mais próximos possíveis. Como nem sempre há uma correspondência exata, às vezes você pode ter que executar dois ou três comandos para obter as informações necessárias.

Usando EVE-NG para teste

No último artigo, usamos GNS3 para emular Cisco IOS e RouterOS para que pudéssemos comparar os diferentes comandos e garantir que a tradução fosse a mais próxima possível. Para este artigo, decidimos usar EVE-NG, pois está se tornando cada vez mais popular para emulação de rede.

Rede para comandos básicos

Cisco commandMikroTik Command
show ip ospf neighborrouting ospf neighbor print
show ip ospf interfacerouting ospf interface print
show ip ospf 1routing ospf instance print detail
show ip ospf databaserouting ospf lsa print
show ip route ospfip route print where ospf=yes
show ip ospf ribrouting ospf route print
show ip ospf border-routersrouting ospf area-border-router print
show ip ospf border-routersrouting ospf as-border-router print
Cisco(config)#router ospf 1/routing ospf instance
Cisco(config-router)#router-id 203.0.113.1/routing ospf instance set 0 router-id=203.0.113.2
Cisco(config-router)#network 203.0.113.1 0.0.0.0 area 0/routing ospf network add area=backbone network=203.0.113.2/32
Cisco(config-router)#network 203.0.113.128 0.0.0.7 area 0/routing ospf network
add area=backbone network=203.0.113.128/29
Cisco(config-router)#interface GigabitEthernet0/0
Cisco(config-if)# ip ospf network point-to-point
Cisco(config-if)# ip ospf dead-interval 4
Cisco(config-if)# ip ospf hello-interval 1
/routing ospf interface add dead-interval=4s hello-interval=1s interface=ether1 network-type=point-to-point

Showing 1 to 13 of 13 entries

Mais artigos Cisco para MikroTik estão a caminho!

Este artigo cobre a maioria dos comandos OSPF comuns. Alguns dos comandos e configurações mais avançados, incluindo OSPF flitering, Virtual and Sham Links, serão abordados em um artigo separado. MPLS e VLANs também estão na lista. Fique atento para mais!

Deixe uma resposta

0