Como configurar balanceamento no Mikrotik usando o Per Connection Classifier (PCC)

Como configurar balanceamento no Mikrotik usando o Per Connection Classifier (PCC)

O PCC é um recurso do Mikrotik routerOS que permite que os  tráfegos sejam divididos em fluxos iguais de pacotes, dando aos administradores a  capacidade de identificar e manter tráfegos específicos restritos a uma conexão predefinida  . Ele pode ser usado para realizar balanceamento de carga com a opção de  failover automático em uma conexão ISP dupla.

Neste post, compartilharei  conosco como configurar o balanceamento de carga em um roteador Mikrotik, usando o PCC. Podemos instruir as conexões que entram através de um ISP para sair através da conexão do mesmo ISP.

Curso Completo Mikrotik

 A configuração abaixo garante que seja alcançado. Primeiro, aborde as interfaces.

Atribuir endereços IP

/ endereço de IP

add address = 172.16.10.1 / 24 network = 172.16.10.0 broadcast = 172.16.10.255 
interface = LAN

add address = 192.168.1.2 / 30 network = 192.168.1.0 broadcast = 192.168.1.3 
interface = ISP1

add address = 192.168.2.2 / 30 network = 192.168.2.0 broadcast = 192.168.2.3 
interface = ISP2

Definir gateways padrão para conexões não marcadas

/ip route

add dst-address=0.0.0.0/0 check-gateway=ping gateway=192.168.1.1,192.168.2.1

Nat regras para tráfegos fora de conexões ISPs

/ip firewall nat

add action=masquerade chain=srcnat comment=”ISP1″ out-interface=ether1

add action=masquerade chain=srcnat comment=”ISP2″ out-interface=ether2

Como queremos garantir que as conexões que chegam através de um ISP saiam pelo mesmo ISP, devemos identificar e manter essas conexões separadas. Usaremos a conexão para marcar as conexões conforme elas vierem através dos ISPs e usar a rota para marcá-las quando elas saírem. Ver abaixo.

Marcar conexões de entrada

/ip firewall mangle

add action=mark-connection chain=input comment=”ISP1_Inbound” in-interface=ether1 new-connection-mark=”ISP1_Inbound”

add action=mark-connection chain=input comment=”ISP2_Inbound” in-interface=ether2 new-connection-mark=”ISP2_Inbound”

Use a Marca de Rota para conexões de saída

add action=mark-routing chain=output comment=”ISP1­_Outbound” connection-mark=”ISP1_Inbound” new-routing-mark=”ISP1_Outbound”

add action=mark-routing chain=output comment=”ISP2_Outbound” connection-mark=”ISP1_Inbound” new-routing-mark=”ISP2_Outbound”

Usando as marcas de rota criadas acima, precisamos definir marcas de rota que identificarão várias conexões. As conexões com endereços de destino que NÃO são dos endereços de LAN serão identificadas e baseadas na marca de rota , usada para classificar a proporção na qual as conexões devem ser estabelecidas em ambos os links do ISP. Ver abaixo:

Definir marcas de rota para conexões de LAN

/Ip firewall mangle

add action=mark-routing chain=prerouting comment=”LAN load balancing 2-0″ \

dst-address-type=!local in-interface=ether3 new-routing-mark=\

“ISP1_Outbound” passthrough=yes per-connection-classifier=\

both-addresses-and-ports:2/0

add action=mark-routing chain=prerouting comment=”LAN load balancing 2-1″ \

dst-address-type=!local in-interface=ether3 new-routing-mark=\

“ISP2_Outbound” passthrough=yes per-connection-classifier=\

both-addresses-and-ports:2/1

Por fim, criamos rotas padrão para usar as marcas de rota acima para balancear a carga em ambos os provedores. Essas rotas padrão garantirão que os tráfegos entrem por meio de um provedor para sair pelo mesmo caminho. Ver abaixo:

Definindo rotas padrão

Rota / ip

adicione distance = 1 gateway = 192.168.1.1 routing-mark = ”ISP1_Outbound”

adicione distance = 1 gateway = 192.168.2.1 routing-mark = ”ISP2_Outbound”

/ip route

add distance=1 gateway=192.168.1.1 routing-mark=”ISP1_Outbound”

add distance=1 gateway=192.168.2.1 routing-mark=”ISP2_Outbound”

Curso Consultor Projetista de Redes Ópticas

A configuração acima garantirá que os tráfegos sejam balanceados em carga nas duas conexões ISP, assegurando que a conexão iniciada por um ISP permaneça com esse ISP, exceto se o link falhar, caso em que a conexão será restabelecida usando o link alternativo. Conexões que não estão marcadas, farão uso da primeira rota padrão configurada que faz do ISP1 a conexão preferida, enquanto o ISP2 é a rota de backup.

Deixe uma resposta

0
YOUR CART
  • No products in the cart.