Bem-vindo a Semeo Consultoria

O que falta para que sua REDE decole?

Envie pacotes do YouTube de um ISP e os pacotes restantes através de outro ISP

Envie pacotes do YouTube de um ISP e os pacotes restantes através de outro ISP

Este laboratório é sobre como compartilhar pacotes entre dois links ISP usando um roteador Mikrotik. Eu configurarei um roteador Mikrotik para enviar pacotes do YouTube de um ISP e os pacotes restantes através de outro ISP. 

A tarefa é garantir que todos os pacotes do YouTube sejam enviados através do ISP2, enquanto todos os outros tráfegos passam pelo ISP1.

Por que alguém desejaria implementar uma política como a que estamos prestes a implementar? Bem, uma das respostas é garantir que os vídeos do YouTube possam transmitir sem problemas sem buffer. Um ISP que tenha usuários que assistem a vídeos do YouTube sempre pode fazer isso como parte da qualidade do serviço.

Topologia de rede

Envie pacotes do YouTube para fora de um ISP

Tarefas a serem executadas

Para atender aos requisitos deste laboratório, as seguintes tarefas serão executadas:

  • Crie um protocolo layer7 para os tráfegos do YouTube.
  • Configure uma regra de filtro de firewall para capturar os endereços IP do Youtube usando o protocolo layer7 criado acima.
  • Configure uma regra de marca de roteamento mangle para marcar o roteamento do YouTube para endereços IP na lista de endereços do YouTube
  • Configure um gateway para os tráfegos do YouTube usando a marca de roteamento criada na etapa três.

Implementação

Para implementar com sucesso a política em um roteador Mikrotik que instruirá o roteador a enviar pacotes do YouTube de um ISP e os demais pacotes via outro ISP, o seguinte comando de configuração será inserido no roteador.

  • Criando o protocolo layer7 para o YouTube
/ ip firewall layer7-protocol add nome = regexp do YouTube = ^. + (youtube.com). * $
  • Criar uma regra de firewall para capturar endereços IP do YouTube e colocá-los em uma lista de endereços de destino
 
/ip firewall filter add chain=forward action=add-dst-to-address-list layer7-protocol=YouTube src-address=192.168.1.0/24 address-list=youtube_IP_address address-list-timeout=0s 
  • Criar uma regra de mangle para marcar rotas para o endereço IP de destino na lista de endereços 
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=YouTube_routing dst-address-list=youtube_traffics 
  • Configurar gateways; um para tráfego do YouTube e outro para outros tráfegos.
/ip route add dst-address=0.0.0.0/0 routing-mark=Youtube_routing gateway=192.168.11.1
add dst-address=0.0.0.0/0 gateway=10.0.0.10

Isso é tudo o que precisamos fazer para alcançar o objetivo deste laboratório. No entanto, se quisermos que os tráfegos do YouTube sejam enviados para o ISP1 no caso de o ISP2 se tornar inacessível, modificamos a tabela de roteamento com os seguintes comandos.

/ip route add dst-address=0.0.0.0/0 routing-mark=Youtube_route gateway=192.168.11.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 routing-mark=Youtube_routing gateway=10.0.0.10 distance=2
add dst-address=0.0.0.0/0 gateway=10.0.0.10

Verificação

Envie pacotes do YouTube de um
Envie pacotes do YouTube para fora de um ISP

As imagens abaixo mostram o resultado de tracerts para youtube.com e bbc.com. Você pode ver que, enquanto o rastreamento para bbc.com passou por 10.0.0.10 (ISP1), o de youtube.com passou por 192.168.11.1 (ISP2).

administrador

Deixe uma resposta

Neste Sabado em uma LIVE a Semeo Consultoria em seu Canal no Youtube vai receber Fabio dono do provedor WEBNET que tem provedor todo em REDE METRO vai contar um pouco da sua experiencia em redes Metros.

Você que tem duvidas sobre redes Metro não pode perder ,ja que estamos ao VIVO vai poder fazer perguntas diretamente a quem entende do assunto. 

Para participar e só se inscrever no campos abaixo ou se inscrever em nosso canal do YOUTUBE , aguardamos você lá