Como configurar MPLS no MikroTik

Como configurar MPLS no MikroTik

MPLS significa Multiprotocol Label Switching. Esta tecnologia de transmissão se tornou uma tecnologia popular e popular por vários anos. MPLS usa um mecanismo de rotulagem para enviar pacotes pela rede. Em geral, se quisermos descrever a função do MPLS, ele realiza a operação de comutação usando o mecanismo de rotulagem na plataforma de roteamento. Ou seja, um pacote é rotulado com base no endereço IP de destino ao entrar na rede MPLS. Em seguida, ele é guiado ao longo do caminho na segunda camada e com base neste rótulo para chegar ao destino. Neste artigo, vamos aprender como configurar MPLS no MikroTik . Você pode visitar os pacotes disponíveis emEldernode comprar Mikrotik VPS servidor.

Tutorial de configuração de MPLS no MikroTik

O MPLS não está localizado em uma camada específica do OSI e sua funcionalidade está localizada entre a segunda camada (enlace de dados) e a terceira camada (Rede). É por isso que ele é apresentado como um protocolo da Camada 2.5. Conforme mencionado, o MPLS usa o mecanismo de etiquetagem na embalagem. Os rótulos MPLS são distribuídos entre os roteadores e os roteadores podem usar esses rótulos para obter um mapa dos rótulos da rede. Esses rótulos se conectam a pacotes IP, permitindo que os roteadores usem esses rótulos para enviar pacotes independentemente do endereço IP. No MPLS, os pacotes são enviados por comutação de rótulo em vez de comutação de IP.

A tecnologia de comutação de etiquetas não é uma tecnologia nova e as redes Frame Relay e ATM a usaram para enviar frames e células. No Frame Relay e no ATM, o rótulo muda em cada salto da rede. Essa é a principal diferença entre essas duas tecnologias e o envio em Pacotes IP. Ele não altera o endereço de destino quando o roteador envia um pacote IP. Na verdade, as tags MPLS são usadas para enviar pacotes e não usam um endereço IP. Na continuação deste artigo, explicaremos como configurar MPLS em MikroTik.

Vantagens do MPLS

Aqui está um resumo dos benefícios de usar MPLS na rede:

– Uso de uma infraestrutura de rede integrada

– Melhor do que IP sobre ATM

– Núcleo livre do Border Gateway Protocol (BGP)

– Otimização do fluxo de tráfego

– Engenharia de Tráfego

– Modelo ponto a ponto para MPLS VPN

Configurar MPLS no MikroTik

Para configurar a rede MPLS, consideramos o seguinte cenário. Este cenário consiste em três roteadores Provider e três roteadores Provider Edge.

Configurar MPLS no MikroTik

A primeira etapa é criar uma interface Loopback em todos os dispositivos. Como não importa se há vários links entre os dois roteadores porque apenas uma sessão LDP é criada, a interface de loopback também pode ser usada para ID LSR e endereço de transporte.

Observe os seguintes comandos:

P1

/interface bridge add name=lobridge
/ip address add address=10.255.255.1/32 interface=lobridge

Observe que os outros roteadores estão configurados para 10.255.255.2-6 conforme mostrado acima:

P2

/interface bridge add name=lobridge
/ip address add address=10.255.255.2/32 interface=lobridge

P3

/interface bridge add name=lobridge
/ip address add address=10.255.255.3/32 interface=lobridge

PE1

/interface bridge add name=lobridge
/ip address add address=10.255.255.4/32 interface=lobridge

PE2

/interface bridge add name=lobridge
/ip address add address=10.255.255.5/32 interface=lobridge

PE3

/interface bridge add name=lobridge
/ip address add address=10.255.255.6/32 interface=lobridge

Treinamento de endereçamento IP

Em seguida, você precisa configurar os endereços IP das interfaces Ethernet dos dispositivos. Verifique os seguintes comandos para este propósito:

P1

/ip address
add address=10.0.255.1/30 interface=ether1
add address=10.0.255.5/30 interface=ether2
add address=10.1.0.254/24 interface=ether3

P2

/ip address
add address=10.0.255.6/30 interface=ether1
add address=10.0.255.9/30 interface=ether2
add address=10.2.0.254/24 interface=ether3

P3

/ip address
add address=10.0.255.10/30 interface=ether1
add address=10.0.255.2/30 interface=ether2
add address=10.3.0.254/24 interface=ether3

PE1

/ip address
add address=10.1.0.1/24 interface=ether1

PE2

/ip address
add address=10.2.0.1/24 interface=ether1

PE3

/ip address
add address=10.3.0.1/24 interface=ether1

Como configurar o roteamento dinâmico

Nesta seção, você deve configurar um Roteamento dinâmico para que a rede seja totalmente acessível. Ao fazer isso, o LDP será capaz de iniciar a rede MPLS Core em sua rede.

P1

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.1 numbers=default
/routing ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.1.0.0/24

P2

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.2 numbers=default
/routing ospf network
add area=backbone network=10.0.255.8/30
add area=backbone network=10.0.255.4/30
add area=backbone network=10.2.0.0/24

P3

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.3 numbers=default
/routing ospf network
add area=backbone network=10.0.255.0/30
add area=backbone network=10.0.255.8/30
add area=backbone network=10.3.0.0/24

PE1

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.4 numbers=default
/routing ospf network
add area=backbone network=10.1.0.0/24

PE2

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.5 numbers=default
/routing ospf network
add area=backbone network=10.2.0.0/24

PE3

/routing ospf instance
set distribute-default=never redistribute-connected=as-type-1 router-id=10.255.255.6 numbers=default
/routing ospf network
add area=backbone network=10.3.0.0/24

Deve-se observar que, após realizar as etapas acima, você agora deve ter um sistema OSPF rooteado:

Como configurar MPLS

Finalmente, você precisa ir para as interfaces Ethernet que deveriam estar na rede MPLA Core e habilitar o LDP nelas:

P1

/mpls ldp
set enabled=yes lsr-id=10.255.255.1 transport-address=10.255.255.1
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

P2

/mpls ldp
set enabled=yes lsr-id=10.255.255.2 transport-address=10.255.255.2
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

P3

/mpls ldp
set enabled=yes lsr-id=10.255.255.3 transport-address=10.255.255.3
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

PE1

/mpls ldp
set enabled=yes lsr-id=10.255.255.4 transport-address=10.255.255.4
/mpls ldp interface
add interface=ether1

PE2

/mpls ldp
set enabled=yes lsr-id=10.255.255.5 transport-address=10.255.255.5
/mpls ldp interface
add interface=ether1

PE3

/mpls ldp
set enabled=yes lsr-id=10.255.255.6 transport-address=10.255.255.6
/mpls ldp interface
add interface=ether1

Agora, na seção Vizinho do LDP na guia MPLS , seus vizinhos do LDP devem ser mostrados a você.

Seção do vizinho LDP no MPLS

Você também pode usar o seguinte comando:

mpls ldp neighbor print

Conclusão

O protocolo MPLS, que é muito popular hoje, oferece a capacidade de rotear pacotes com base em um método mais recente. Também elimina a necessidade de roteamentos de IP antigos e roteamento de nossos pacotes em uma velocidade mais alta. Neste artigo, tentamos informá-lo sobre como configurar o MPLS no MikroTik.

Deixe uma resposta

0