Bem-vindo a Semeo Consultoria

O que falta para que sua REDE decole?

O que é CGNAT

O que é CGNAT

CGNAT é real e uma solução paliativa encontrada pelos principais provedores de internet para suprir a demanda por novos endereços IP diante do esgotamento do número de endereços IPv4 disponíveis e a falha na implementação ágil de endereços IPv6.

É uma solução adotada em diversos países há anos, regulamentada pelas entidades governamentais responsáveis mas que pode resultar em problemas para o consumidor em alguns cenários específicos.

A recomendação da NIC.BR para aqueles que se sentirem prejudicados pela prática é entrarem em contato com seus provedores de acesso à internet e negociarem a obtenção de um endereço IPv4 tradicional ou a configuração adequada de roteador para habilitar portas e conexões ponto a ponto, dependendo do caso.

Há registro de provedores que ainda possuem disponibilidade de endereços IPv4 ou com capacidade técnica para atender à solicitação de seus usuários.

Seu Mikrotik tambem faz o CGNAT ,neste post vamos dar um exemplo de como configurar o cgnat em seu mikrotik.

Quando e Como usar:- Casos de hotspots públicos;- Provedores sem AS com muito poucos IPs;- Para dividir as portas tem que pensar quantos IPs privados vai colocar em cada IP público.


Vantagem:- Colocar vários “Range de IPs Privados” em 1 único IP público;
– O Range de IPs Privados ficando dentro de 1 IP público a contagem de portas não se perde. A cada Range de IPs Privado novo uso um novo IP público.


Desvantagem:- Muitas regras, pois são 2 (TCP, UDP) pra cada IP interno mais os jumps pra otimizar;
– Como são tantas regras o ICMP com certeza você vai escolher um IP qualquer para todos os clientes usarem, mesmo que seja diferente do IP que o cliente normalmente usa.

Exemplo de implementação com mikrotik:

/ip firewall nat
add action=jump chain=srcnat comment=CGNAT jump-target=CGNAT-192.0.2.160 out-interface=BridgeBackbone src-address=100.64.0.0/25
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-0 src-address=100.64.0.0/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-1 src-address=100.64.0.16/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-2 src-address=100.64.0.32/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-3 src-address=100.64.0.48/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-4 src-address=100.64.0.64/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-5 src-address=100.64.0.80/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-6 src-address=100.64.0.96/28
add action=jump chain=CGNAT-192.0.2.160 comment=CGNAT jump-target=CGNAT-192.0.2.160-7 src-address=100.64.0.112/28
add action=src-nat chain=CGNAT-192.0.2.160-0 comment=CGNAT protocol=tcp src-address=100.64.0.0 to-addresses=192.0.2.160 to-ports=1500-1999
add action=src-nat chain=CGNAT-192.0.2.160-0 comment=CGNAT protocol=udp src-address=100.64.0.0 to-addresses=192.0.2.160 to-ports=1500-1999
add action=src-nat chain=CGNAT-192.0.2.160-0 comment=CGNAT protocol=tcp src-address=100.64.0.1 to-addresses=192.0.2.160 to-ports=2000-2499
add action=src-nat chain=CGNAT-192.0.2.160-0 comment=CGNAT protocol=udp src-address=100.64.0.1 to-addresses=192.0.2.160 to-ports=2000-2499
...
...
...
add action=src-nat chain=CGNAT-192.0.2.160-7 comment=CGNAT protocol=tcp src-address=100.64.0.126 to-addresses=192.0.2.160 to-ports=64500-64999
add action=src-nat chain=CGNAT-192.0.2.160-7 comment=CGNAT protocol=udp src-address=100.64.0.126 to-addresses=192.0.2.160 to-ports=64500-64999
add action=src-nat chain=CGNAT-192.0.2.160-7 comment=CGNAT protocol=tcp src-address=100.64.0.127 to-addresses=192.0.2.160 to-ports=65000-65499
add action=src-nat chain=CGNAT-192.0.2.160-7 comment=CGNAT protocol=udp src-address=100.64.0.127 to-addresses=192.0.2.160 to-ports=65000-65499

Lembrando que na internet você não acha uma formula magica que você irá pegar e colocar no seu mikrotik procure entender o que você esta fazendo…

administrador

Deixe uma resposta