Como entender a interface de linha de comando do Mikrotik

Como entender a interface de linha de comando do Mikrotik

A interface de linha de comando do Mikrotik, acessível através do novo console, a janela do terminal em routerOS ou através de um emulador de terminal como telnet ou ssh, é uma das poucas funcionalidades que a maioria dos usuários do Mikrotik gosta de utilizar. Graças à interface gráfica fácil de usar disponível no winbox.

Curso Completo Mikrotik

A experiência tem mostrado que há momentos em que um roteador não pode ser acessado via winbox, seja como resultado de regras firewall configuradas , roteamento de conexões proplem ou ruins através de um link sem fio. Em tais situações, o usuário pode fazer uso de telnet ou ssh para acessar o roteador. Mas o que você pode fazer em tal situação se você não tem conhecimento básico da interface de linha de comando do Mikrotik? Neste post, veremos a maneira mais simples de entender a interface de linha de comando do Mikrotik.

Além de fornecer um modo de acesso seguro ao roteador via ssh, o comando Mikrotik lind interface também acelera o tempo de configuração nos roteadores Mikrotik e facilita a replicação de configurações em outros roteadores Mikriotik copiando e colando comandos de configuração.

Como entender a interface de linha de comando do Mikrotik

Embora existam informações limitadas sobre a linha de comando do Mikrotik, como a maioria dos usuários prefere o caminho mais fácil através do Winbox, entender como usar a linha de comando do Mikrotik é bem simples. Usando o Winbox, você pode ensinar como usar a interface de linha de comando. As etapas realizadas para realizar uma tarefa através da GUI do Winbox também podem ser executadas ao inserir comandos na CLI. Por exemplo, para atribuir um endereço IP a ether1 por meio da GUI, os seguintes passos serão destacados na imagem abaixo.

Atribuindo Endereços IP

linha de comando do mikrotik

A mesma tarefa pode ser feita usando a linha de comando do Mikrotik simplesmente seguindo os passos destacados na imagem acima. Veja a linha de comando equivalente abaixo.

/ip address add address=192.168.11.1/24 interface=ether1 . Simples! A versão da linha de comando do Mikrotik vem mais curta e mais rápida com os passos 1 a 5 usados.

Configurando rotas padrão / estáticas

linha de comando do mikrotik

Seguindo os passos destacados na imagem acima, a linha de comando equivalente a Mikrotik para realizar a mesma tarefa é dada abaixo

i ip route add dst-address=0.0.0.0/0 gateway=10.0.0.10 . Assim como no primeiro exemplo, este contém cinco das sete etapas destacadas na versão da GUI. Conseguimos a versão CLI seguindo os passos da versão GUI, excluindo “apply” e “okay”.

Curso Consultor Projetista de Redes Ópticas

Para configurar uma rota estática para uma rede de destino, nós simplesmente mudamos o endereço de destino de 0.0.0.0/0 para o endereço de rede que estamos tentando acessar, por exemplo, 192.168.88.0/24. Ver abaixo.

/ip route add dst-address=192.168.88.0/24 gateway=10.0.0.10.

Vamos ver um exemplo de como configurar regras NAT no Mikrotik, usando as versões GUI e CLI.

Configurando o NAT no Mikrotik

linha de comando do mikrotik
linha de comando do mikrotik

A versão CLI é dada abaixo.

/ /ip firewall nat add chain=srcnat src-address=192.168.88.0/24 action=masquerade  . Muito simples e fácil!

Se você gostou deste tutorial se inscreva em nosso CANAL no YOUTUBE

Deixe uma resposta

0